phpCOIN Multiple Vulnerabilities

There is a fix: http://www.phpcoin.com/addons/dload.php?id=30

Seem to remember someone is using this around here.