Results 1 to 6 of 6

Thread: Laptop hardware question - USB ports

  1. #1
    Senior Member Jonathan's Avatar
    Join Date
    Mar 2004
    Location
    Daytona Beach, FL / Rochester, NY / Coeur d'Alene, ID
    Posts
    1,229

    Default Laptop hardware question - USB ports

    OK so my laptop decided not to let its USB ports work anymore
    They'll work sometimes then stop. I know this, because I honestly cannot
    stand the touchpad mouse device on laptops. I use a MS Trackball.

    Well of course, I love photography. Right now its the only relaxing thing
    I have left since my car stopped working and I'm having to wait and save
    to fix it (and this means taking myself off the insurance so I can't drive period).

    But since USB isn't working... I can't hook my flash-memory reader up.
    Under Device Manager it says 'Base System Device - ?' ~ I'm guessing the mobo?
    I cannot recall if I had ever reinstalled windows on this device.
    Would that be a problem? Maybe the drivers for the mobo are missing?
    Hence not recognizing the USB ports? All 3 of them have same issues.
    OR do I need to install a USB driver? Since I'm not sure if I had wiped my HD...

    OR is it a hardware problem? A connection came undone, etc?
    "How can someone be so distracted yet so focused?"
    - C

  2. #2
    Senior Member
    Join Date
    Apr 2004
    Location
    Manchester, UK
    Posts
    168

    Default

    I'd guess you need drivers from the laptop manufacturer - most if not all will have them for download... - strange that the USB ports sometimes work though???

    I hear what your saying about the touchpad mouse, although having turned off the "tap to click" option it i find it much more useable

  3. #3
    Senior Member Jonathan's Avatar
    Join Date
    Mar 2004
    Location
    Daytona Beach, FL / Rochester, NY / Coeur d'Alene, ID
    Posts
    1,229

    Default

    I've re-downloaded all the drivers from mfg's website.
    I have a CyberPower PC laptop, btw. Its the best computer I've owned
    Never had a problem in 3yrs that I've had it until now. I just really don't
    care to take it to my local PC shop (their really good in services/prices though)
    unless I have to. But the drivers don't make a difference..
    "How can someone be so distracted yet so focused?"
    - C

  4. #4
    Senior Member
    Join Date
    Mar 2004
    Posts
    329

    Default

    Have you tried anything else on that USB besides that USB memory reader?

  5. #5
    Senior Member Jonathan's Avatar
    Join Date
    Mar 2004
    Location
    Daytona Beach, FL / Rochester, NY / Coeur d'Alene, ID
    Posts
    1,229

    Default

    I tried every USB device I own (external 120GB HD, 3 mice, and memory reader).
    All failed to work on my laptop and rest worked on the family PC. I don't have
    my own desktop PC.

    I ended up taking to down to the local PC store that I have alot of positive experiance
    with. In the end they said some spyware/adware that the one program I was using
    (Ad-Aware) was missing and it was bogging the processor down. After clearing that
    off everything works now. But the USB connections on the motherboard is a little
    loose. Nothing they can do to fix it. Blah. But it works for now...
    "How can someone be so distracted yet so focused?"
    - C

  6. #6
    Senior Member
    Join Date
    Apr 2004
    Location
    Manchester, UK
    Posts
    168

    Default

    Glad you got it back up and running

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •