Results 1 to 2 of 2

Thread: Cannot get e-mail accounts to authenticate with BlackBerry

  1. #1
    Junior Member
    Join Date
    Jun 2009
    Posts
    1

    Default Cannot get e-mail accounts to authenticate with BlackBerry

    Hello,

    I'm just curious if anyone else has run into this problem... Right now I have been continuously un-successful in adding a dathorn hosted e-mail account to a BlackBerry phone. The crazy thing is, we've been able to in the past. However recently its been the same brick wall again and again.

    Depending on my customer's carrier, you normally visit <carrier>.blackberry.com (so if you had sprint, you'd visit sprint.blackberry.com) to access your BIS account or BlackBerry Internet Services account. This is a very simple web interface you are required to use to add an e-mail account. It will first attempt to find the settings on it's own based on the e-mail address you provide, but normally I'll skip ahead until it allows you to manually enter your settings. Basically asks for 4 things, the username, mail server (mail.domain.com), password, and of course the e-mail address. You enter all of this in, submit, and then wait and pray that it works. However to my <sarcasm>great surprise</sarcasm> it returns an error that it could not find and authenticate with the specified server.

    When I first encountered this, it was after several attempts of the customer trying to get their e-mail to work themselves. So my first thoughts went to blacklisted, but how do you lookup an IP of what looks like a web app. How do you determine the method that this BIS website connects to an e-mail server?

    I worked with AndrewT quite extensively on this but, without a method of returning an IP address has stumped us. During my first encounter, after several hours of searching the web and attempting to contact BlackBerry, I found a large list of IP ranges that could potentially be related to the BIS website. Gave the list to AndrewT and he graciously searched for them. One result came up, he unblocked it, and bam, we were able to get the BlackBerry website to connect and authenticate the e-mail account and the user's been getting e-mail since.

    However we've since encountered this problem on multiple occasions, none of which we've been able to find an IP that was blacklisted. We even purposely entered invalid data that we know wouldn't authenticate and then worked with AndrewT to see if he saw any invalid connections coming into the server. Nothing showed up.

    We have no issues with any other device, Windows Mobile, iPhone, and Palm OS devices all connect, and send/receive e-mail without a problem. The BlackBerrys however make you want to scream. If we are able to connect a user using their BIS account, the world explodes in joy and they never have any issues sending/receiving mail ever.

    I'm just curious if anyone else has experienced similar issues and has any insight on the matter.

  2. #2
    Junior Member
    Join Date
    Dec 2006
    Posts
    3

    Default

    I don't know why you're not receiving mail on your Blackberry. It's never been a problem with me. I receive and send emails using the Dathorn servers just fine.

    My complaint would be I wish that Dathorn offers "PUSH" email with their service. Or provide Microsoft Exchange Servers as a service. In this regard, Dathorn email service is quite a bit primitive.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •