Results 1 to 3 of 3

Thread: Uber Uploader

  1. #1
    Junior Member
    Join Date
    Jun 2006
    Posts
    16

    Default Uber Uploader

    Does anyone else have experience using Uber Uploader at Dathorn?

    http://uber-uploader.sourceforge.net/

    I have a site which has been using Uber Uploader since 2007, but which suddenly began giving flength errors around April 2009 for some users (not all). It seems that users on slower connections started getting errors consistently around April 2009 despite zero changes to the files on the server.

    For example, users at an office were able to use it for 2 years without a problem. Suddenly, they receive errors each time they attempt to use it, although nothing changed on the server. If that same user takes their laptop home, they can then upload files perfectly fine. So, again, starting April 2009 if users are on a slower connection then Uber Uploader fails.

    The current working theory speculates that perhaps some server configuration changed which may have impacted this.

    I'd like to know if anyone else here is using Uber Uploader and if they've encountered this problem or if there are no reported errors with your instance.

    Thanks!
    Last edited by SeanCustomer; 07-21-2009 at 11:09 AM.

  2. #2
    Junior Member
    Join Date
    Jul 2006
    Posts
    13

    Default

    Hi Sean

    I installed uber years ago (version 3.6 or so) and just went to do an update today and now am getting an error of invalid parameters passed.

    Is this anything you've experienced? Any suggestions on anything you needed to do differently on the dathorn server? I've followed the instructions well, but must be missing something.

    Did you need to modify path to perl or anything else out of the ordinary?

    Thanks! Sean

  3. #3
    Junior Member
    Join Date
    Jul 2006
    Posts
    13

    Default

    Hi again

    tinkered for a while and got it to work most of the time. I am having a problem with it displaying the file length during the upload. On the help page, they mention:

    Assuming the script is set up properly, you are probably dealing with some kind of server side write-caching. Some servers perform write-caching which prevents writing out the flength file or the entire CGITemp file during the upload. The flength file or the CGITemp file do not actually hit the disk until the upload is complete, making it worthless for reporting on progress during the upload. So far 3 reasons have been identified along with possible fixes.

    1. A mod_security module for Apache
    This may be fixed using a .htaccess file assuming your host supports them. To fix it just create a file called .htaccess (that's a period followed by "htaccess") and put the following lines in that file. Upload the file into the directory where the Uber-Uploader CGI ".pl" scripts resides, or in some directory above it (like your server's DOCUMENT_ROOT, i.e. the top-level of your webspace). .htaccess files must be uploaded as ASCII mode, not BINARY. You may need to CHMOD the .htaccess file to 644 or (RW-R--R--).

    <IfModule mod_security.c>
    # Turn off mod_security filtering.
    SecFilterEngine Off

    # The below probably isn't needed,
    # but better safe than sorry.
    SecFilterScanPOST Off
    </IfModule>

    If the above method does not work, try putting the following lines into the file

    <IfModule mod_security.c>
    SetEnvIfNoCase Content-Type \
    "^multipart/form-data;" "MODSEC_NOPOSTBUFFERING=Do not buffer file uploads"
    </IfModule>

    <IfModule mod_gzip.c>
    mod_gzip_on No
    </IfModule>



    I tried to use those suggestions and still nothing; so on longer files it appears to fail and display "failed to find flength file"

    any ideas on how to turn off write caching on one site or one script?

    Sean

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •