In case any of your missed it, updates to both Joomla 2.5.x and 3.1.x were made available on August 1st which fix a critical vulnerability that can grant attackers access to your entire account and permit arbitrary command execution. It is absolutely imperative that you update your scripts as soon as possible. Further, you should not be running any version prior to 2.5.14. Versions 1.0/1.5/1.6/1.7/etc. reached their end of life some time ago, are no longer being maintained, and are not permitted.